欢迎光临
我们一直在努力

composer的zlib_decode等错误解决

1、报 [ErrorException] zlib_decode(): data error 错 。
解决办法:执行 composer self-update 即可。

2、在执行迁移或者数据填充时发生「class not found」错误 。

解决办法:试着先执行 composer dump-autoload 命令后再进行一次。

3、提示以下类似的错误时

Problem 1
- The requested package graham-campbell/credentials ~1.0 is satisfiable by graham-campbell/credentials[1.0.x-dev] but these conflict with your requirements or minimum-stability.

解决方法:在composer.json中添加以下

"minimum-stability": "dev",

4、Deprecation Notice: The Composer\Package\LinkConstraint\LinkConstraintInterface interface is depreca

Deprecation Notice: The Composer\Package\LinkConstraint\MultiConstraint class is deprecated, use Composer\Semver\Constraint\MultiConstraint instead. in phar:///usr/local/bin/composer/src/Composer/Package/LinkConstraint/MultiConstraint.php:17
Deprecation Notice: The Composer\Package\LinkConstraint\LinkConstraintInterface interface is deprecated, use Composer\Semver\Constraint\ConstraintInterface instead. in phar:///usr/local/bin/composer/src/Composer/Package/LinkConstraint/LinkConstraintInterface.php:17

在使用composer global require "fxp/composer-asset-plugin:^1.2.0"的时候提示上面的错误,解决方法是只要删除电脑里的fxp目录就可以了。具体操作就是:

rm -rf ~/.composer/vendor/fxp

未经允许不得转载:发现未来 » composer的zlib_decode等错误解决

分享到:更多 ()

评论 抢沙发

评论前必须登录!

 

发现网服务 更专业 更方便

广告联系联系我们