最新消息:网站全新发布上线,继续为大家提供更多实用帮助。

phpStudy升级Mysql到5.7.17版本

服务器运维 louis 14200 0 评论
最近学习laravel5.5一段时间了,发现laravel5.5的环境需要mysql5.7版本,不适用mysql5.7版本就会在使用php artisan migrate的数据库迁移命令的时候报错,解决办法只有修改框架的代码才行,今天觉得还是升级phpStudy的mysql版本到5.7比较好,一劳永逸。1、首先下载phpStudy的集成环境:http://phpstudy.php.cn/download.html2、解压安装phpStudy的集成环境软件,该环境目前的mysql版本是5.5的。3...

最近学习laravel5.5一段时间了,发现laravel5.5的环境需要mysql5.7版本,不适用mysql5.7版本就会在使用php artisan migrate的数据库迁移命令的时候报错,解决办法只有修改框架的代码才行,今天觉得还是升级phpStudy的mysql版本到5.7比较好,一劳永逸。

1、首先下载phpStudy的集成环境:http://phpstudy.php.cn/download.html

2、解压安装phpStudy的集成环境软件,该环境目前的mysql版本是5.5的。

3、下载mysql 5.7.17版本,官方下载地址:https://dev.mysql.com/downloads/file/?id=467269

4、停止phpStudy的服务(apache、nginx、mysql)并将X:/phpStudy/PHPTutorial目录下的MySQL文件夹重命名为“MySQL-Bak”以防止操作失误可以恢复数据。

5、将下载好的mysql-5.7.17-winx64.rar解压并将文件夹重命名为“MySQL”,复制一份文件夹中的my-default.ini文件改名为“my.ini”,配置my.ini文件如下:

basedir = "X:\phpStudy\PHPTutorial\MySQL" #mysql的安装路径
datadir = "X:\phpStudy\PHPTutorial\MySQL\data" #data的路径

6、将之前备份的MySQL-Bak文件夹里的data文件夹复制到MySQL目录下。

现在基本就完成了mysql版本的升级,假如遇到mysql无法启动的情况,检查是不是有mysql的服务安装过,如果安装过mysql可以在cmd命令行下输入:sc delete mysql 即可删除。

转载请注明: 访得 » phpStudy升级Mysql到5.7.17版本

赞 (0) or 打赏
支付宝 微信
游客 发表我的评论   换个身份
取消评论

表情
(0)个小伙伴在吐槽